Commit 95cae560 authored by viscapi's avatar viscapi
Browse files

Added some more details to README file

parent 13f9be08
......@@ -3,12 +3,15 @@ Read Me
1. About
These Ansible roles allow you to install, from a deployment host, iRODS [4.2.0 - 4.2.8] on one or more CentOS 7.x x86_64 hosts. The iRODS role is compatible with both provider and consumer installation modes. PostgreSQL (from 9.4 to 13 on CentOS 7.x or 10.6 on CentOS 8.x) will be used to serve the iCAT catalogue. All firewalls should be stopped before attempting a deployment.
These Ansible roles allow you to install, from a deployment host, iRODS [4.2.0 - 4.2.8] on one or more CentOS 7.x x86_64 hosts. The iRODS role is compatible with both provider and consumer installation modes. PostgreSQL (stock versions from the distribution or newer ones) will be used to serve the iCAT catalogue. All firewalls should be stopped before attempting a deployment.
2. Ansible installation
```bash
yum install epel-release # as root
yum update # as root
yum install python2-pip # as root
pip install --upgrade pip # as root
pip install ansible --user # first installation
pip install -U ansible --user # update
```
......@@ -25,6 +28,7 @@ This Gitlab repository is comprised of two Ansible roles:
4. Fetch the roles
```bash
yum install git # as root
mkdir -p ansible/{group_vars/{iRODS,all},host_vars,roles} ; cd ansible
$ git clone https://dci-gitlab.cines.fr/poc_irods/poc-irods.git roles
```
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment