Commit b1db1538 authored by Louis VINCHON's avatar Louis VINCHON
Browse files

Role irods: clean up 'centos' tasks

Remove anything that is not CentOS-specific.
parent b81a0c5c
......@@ -8,16 +8,5 @@
- irods-server-{{ irods_version }}
- irods-database-plugin-postgres-{{ irods_version }}
state: present
when: ansible_facts['distribution'] == "CentOS"
- name: Install iRODS packages and misc. on Ubuntu
package:
name:
- python-apt
- python-pip
- irods-server={{ irods_version }}
- irods-database-plugin-postgres={{ irods_version }}
state: present
when: ansible_facts['distribution'] == "Ubuntu"
...
......@@ -19,24 +19,7 @@
gpgkey: https://packages.irods.org/irods-signing-key.asc
repo_gpgcheck: no
state: present
when: (ansible_facts['distribution'] == "CentOS" and ansible_facts['distribution_major_version'] == "7" and not use_local_mirror)
- name: Add key and iRODS repository on Debian / Ubuntu
block:
- name: Add key for iRODS repository on Debian / Ubuntu
apt_key:
url: https://packages.irods.org/irods-signing-key.asc
state: present
validate_certs: yes
- name: Add iRODS repository on Ubuntu 18
apt_repository:
repo: "deb [arch=amd64] https://packages.irods.org/apt/ {{ ansible_distribution_release }} main"
state: present
filename: renci-irods
update_cache: true
validate_certs: yes
when: ansible_facts['distribution'] == "Ubuntu"
when: (ansible_facts['distribution_major_version'] == "7" and not use_local_mirror)
...
......@@ -4,6 +4,5 @@
selinux:
policy: targeted
state: "{{ selinux_mode }}"
when: ansible_facts['distribution'] == "CentOS"
...
---
- name: Install iRODS for CentOS.
import_tasks: centos/main.yml
when: ansible_facts['distribution'] == "CentOS"
...
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment